[Resolvido] Erro ao atualizar meu kali linux


#1

Após editar meu repositório do kali linux não consegui atualizar. Lembrando que editei com o repositório atual e que inclusive postaram em uma dúvida, mas dá o seguinte erro:

Obter:1 http://kali.mirror.globo.tech/kali kali-rolling InRelease [30,5 kB]
Err:1 http://kali.mirror.globo.tech/kali kali-rolling InRelease
As seguintes assinaturas eram inválidas: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository [email protected]
Baixados 30,5 kB em 4s (6.598 B/s)
Lendo listas de pacotes… Pronto
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://kali.mirror.globo.tech/kali kali-rolling InRelease: As seguintes assinaturas eram inválidas: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository [email protected]
W: Falhou ao buscar http://http.kali.org/kali/dists/kali-rolling/InRelease As seguintes assinaturas eram inválidas: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository [email protected]
W: Falhou o download de alguns ficheiros de índice. Foram ignorados ou os antigos foram usados em seu lugar.
W: Target Packages (main/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list:9
W: Target Packages (main/binary-all/Packages) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list:9
W: Target Translations (main/i18n/Translation-pt_BR) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list:9
W: Target Translations (main/i18n/Translation-pt) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list:9
W: Target Translations (main/i18n/Translation-en) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list:9
W: Target DEP-11 (main/dep11/Components-amd64.yml) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list:9
W: Target DEP-11 (main/dep11/Components-all.yml) is configured multiple times in /etc/apt/sources.list:7 and /etc/apt/sources.list:9


#2

Opa Neemias blz!
Tente editar esta source.list que peguei na docs.kali.org:

deb http://http.kali.org/kali kali-rolling main contrib non-free

For source package access, uncomment the following line

deb-src http://http.kali.org/kali kali-rolling main contrib non-free

Há 2 dias atrás o site passou por instabilidade, também pode ser isso novamente.


#3

@Neemias, apague o que está atualmente na sua sources.list e utilize o repositório original indicado no site do Kali:

http://docs.kali.org/general-use/kali-linux-sources-list-repositories

Depois disso, dê um:

####apt-get update && apt-get dist-upgrade

E veja se funcionou :smiley:


#4

Rapaz, mesmo colocando exatamente como está no repositório original continua dando erro…

As seguintes assinaturas eram inválidas: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository [email protected]
Lendo listas de pacotes… Pronto
W: An error occurred during the signature verification. The repository is not updated and the previous index files will be used. GPG error: http://kali.mirror.globo.tech/kali kali-rolling InRelease: As seguintes assinaturas eram inválidas: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository [email protected]
W: Falhou ao buscar http://http.kali.org/kali/dists/kali-rolling/InRelease As seguintes assinaturas eram inválidas: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository [email protected]
W: Falhou o download de alguns ficheiros de índice. Foram ignorados ou os antigos foram usados em seu lugar.


#5

Pessoal, consegui resolver da seguinte forma:

Primeiramente execute no terminal o comando abaixo para baixar o pacote de atualizacão da chave criptográfica

[email protected]:~# wget https://http.kali.org/kali/pool/main/k/kali-archive-keyring/kali-archive-keyring_2018.1_all.deb

Após baixar, execute a instalacão do pacote conforme comando abaixo:

[email protected]:~# dpkg -i kali-archive-keyring_2018.1_all.deb

Agora poderá realizar a atualizacão e instalacão dos pacotes atualizáveis.

[email protected]:~# apt update && apt upgrade


#6

Excelente dica, resolveu meu problema